苹果公司将在2018年愚人节后不再接受watchOS 1应用的更新

苹果今天发布了一个新的开发者博客,告知watchOS应用开发者他们需要将他们的watchOS 1应用更新到最新的watchOS SDK,直到2018年4月1日(愚人节)。 在博客中,Apple敦促所有的watchOS应用程序

苹果今天发布了一个新的开发者博客,告知watchOS应用开发者他们需要将他们的watchOS 1应用更新到最新的watchOS SDK,直到2018年4月1日(愚人节)。

在博客中,Apple敦促所有的watchOS应用程序开发者确保他们的应用程序是最新的,本地的,使用watchOS 2或者watchOS 4 SDK(软件开发工具包)构建。但是,新的watchOS应用程序只需要使用watchOS 4 SDK。

该公司表示,在2018年愚人节之后,它不会接受第一代watchOS应用程序的更新,所以如果你仍然有为watchOS 1生态系统建立的应用程序,你需要确保它们更新到最新的SDK或你将无法触摸它们。

苹果公司表示:“请注意,从2018年4月1日起,watchOS 1应用程序的更新将不再被接受。“更新必须是使用watchOS 2 SDK或更高版本构建的本地应用程序。新的watchOS应用程序应该使用watchOS 4 SDK或更高版本构建。”


苹果希望开发者更新到watchOS 4和Apple Watch Series 3


为鼓励应用程序开发人员将旧版watchOS应用程序更新到最新的watchOS SDK,Apple概述了Apple Watch设备的watchOS 4操作系统的一些很酷的功能,例如将watchOS应用程序捆绑的大小限制从50MB增加到75MB 。

另外,开发者可以充分利用苹果公司在watchOS 4中实现的众多新功能,例如性能提升,音频录制和导航的新背景模式以及直接连接到Core蓝牙的配件。

当然,这些功能中的一部分功能只支持运行watchOS 4或更新版本的最新Apple Watch Series 3 smartwatch,并且可以让您的watchOS应用程序随时随地连接,即使没有iPhone。如果可能的话,苹果鼓励开发者也更新到Apple Watch Series 3。

与此同时,苹果公司继续增加改进功能,并为即将到来的watchOS 4.2软件更新(watchOS 4.2操作系统)启用新功能,该软件目前处于测试阶段。鼓励开发者安装最新的watchOS 4.2 beta 3版本,如果他们想让他们的应用程序保持最新的话。



上一篇:ghostbsd 11.1操作系统降低对32位的支持   |  下一篇:微软发布具有几个新功能的Windows 10 Build 17040